CFDs are complex instruments and come with a high risk of losing money rapidly due to leverage. 64 % of retail investor accounts lose money when trading CFDs with this provider. You should consider whether you understand how CFDs work and whether you can afford to take the high risk of losing your money.

Dax not working with EA

Hi,
I use an EA to trigger trades on Dax but i get mess
“RenkoBuy GDAXI,M3: invalid lots amount for OrderSend function”

I use the lotsize 0.01 thats working manualy, what to do ?

This lotsize works for an EA. If you have the source you can insert a print statement, if not, try to copy the EA message and the messages from the journal to that incident and show it here.
Do you use MT4 or MT5?

I use MT4 i already send the messages “RenkoBuy GDAXI,M3: invalid lots amount for OrderSend function”

You have messages in the EA tab AND in the journal. Usually they are different.
To help here both are needed.

Is the EA self written or bought?

Were can i find the message send by the EA ?

On the tab left from the journal

Journal :
2019.11.21 13:55:55.985 Expert RenkoBuy GDAXI,M3: loaded successfully
Expert :

2019.11.21 13:56:26.500 RenkoBuy GDAXI,M3: invalid lots amount for OrderSend function

Decimal point is point and not comma in your input?
Lotsize defined as double and not integer?

I use this EA for a long time it always worked before
the problem is with Darwinex i think

Don’t see that. I also used 0.01 lots and it worked fine. The specification also show that as minimum size.

Thanks for your comments i will take another look later today.

Try it also on a demo Darwinex account with NDX. Some simple programmed EAs have problems with asset names with less or more than 6 characters length.

1 Like

Its works with Forex just took a trade on EURNZD