CFDs are complex instruments and come with a high risk of losing money rapidly due to leverage. 66 % of retail investor accounts lose money when trading CFDs with this provider. You should consider whether you understand how CFDs work and whether you can afford to take the high risk of losing your money.

Issue with MetaTrader 4 on Windows 10 64-bit

Hi trying to install Darwinex Mt4 on a new PC I got this message from w10.

The same installation works fine on a different pc and same os, Any advice how to fix it?
same thing happens with the mt5 installer.

Thank you

1 Like

Hi there @MatPed

Seems like a faulty registry. I suggest doing these few steps to get it fixed.

First step:

  1. On your keyboard, press Windows Key+R. This should bring up the Run dialog box.
  2. Type “regedit” (no quotes), then press Enter.
  3. Navigate to this path: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
  4. Go to the right pane, then double-click LoadAppInit_DLLs.
  5. Change the value data from 1 to 0.
  6. Save the changes by clicking OK.
  7. Exit the Registry Editor, then restart your computer.

if that does not work then:

  1. Click the Search icon on your taskbar.
  2. Type “cmd” (no quotes).
  3. Right-click Command Prompt from the results, then choose Run as Administrator from the options.
  4. Once Command Prompt is up, type “sfc /scannow” (no quotes), then press Enter. The tool will automatically repair the corrupt system files it will find.

Let us know if it worked.
Kind regards,

3 Likes

Hello @MatPed,

Since W10 initial release, there was a lot of MT4 issues at each MS update… (one of main/classical issues being : (saved) credentials are erased after update).

So, it can be tricky to pinpoint exact root cause due to wide range of symptoms/causes.

In your case, you don’t even manage to launch MT4 setup. So, besides @SkyField advices, it can also be due to :

- Need to define legacy compatibility (as W98) in such executable properties
- Disable (temporarily) some security softwares (as antivirus, etc.)

Keep us updated.

Sincerely,

SECURIX

1 Like

First try to ensure that you have installed all updates using Settings -> Update & Security -> search for updates

There were 2 updates sleeping which were not automatically installed which win 10 usually does.

I had to reinstall my virus scanner after the weekend updates only on the HP Laptop (my newest device here) because they removed the home net again over the weekend (shown as message) as they did months ago. That feature is not supported by win 10 since about half a year, but when it was installed anytime it could also cause problems with any win update later touching it.

I also run 1 PC and 1 HP Laptop with 2 real different win 10 installations.

2 Likes

Hi all,
thank you for your support. Unfortunately all the suggestions given did not work. (regedit, scanning tool, upgrade and disable all security,
I have attached a link to my log from the scanning tool. Maybe someone more exert than me can identify the issue.

http://gofile.me/6xWCE/jBR6qd4GM

you mean HKEY_LOCAL_MACHINE?

HKEY_LOCAL_MACHINE = HKLM :slight_smile:

Intentarlo con la MT5, yo uso win10 y me vá bien .

SAme issue with Mt5 installer. Thank You

Hello @MatPed,

Let me suppose that the troubleshooting will be a mix of all suggestions (@SkyField, @IlIlIlIlI, mine, etc.) :slight_smile:

Let me present my diagnostic :

@SkyField : suggested you to do a sfc scan. Nice suggestion, leading you to this CBS.log .

To parse it quickly, search for [SR] string.

You’ll find the culprit :

Primitive installers committed for repair : that is, indeed your issue (Installer fails to launch).

@IlIlIlIlI : suggested to do all the security updates, sharing misadventures with antivirus reinstalls, etc.

As I pointed out initially, by experience, your issue can be an unfortunate consequence of X simultaneous issues :slight_smile:

My supposed conclusion :

July updates were proven to f*ck up a lot of things, you’ll find the similar issue you are getting here :

https://borncity.com/win/2019/07/11/windows-july-9-2019-updates-breaks-sfc/

August updates fixed it :

https://borncity.com/win/2019/08/19/microsoft-fixes-the-windows-defender-sfc-bug-august-2019/

But, as your system already was f*cked up, system updates you just did can’t fix it : I suppose you need to do a clean/fix as explained in first article, and then, redownload Darwinex setup and try again :slight_smile: .

By the way, would be fine to double-check which MD5 checksum you have after downloading MT4 setup :

https://download.mql5.com/cdn/web/tradeslide.trading.tech/mt4/darwinex4setup.exe

Should be :

MD5 (Downloads/darwinex4setup.exe) = c029c175f74e04a8bf9f140d0d8cfe03

Good luck and keep us updated :slight_smile: .

2 Likes